summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAuke Kok <auke-jan.h.kok@intel.com>2012-10-17 16:01:12 -0700
committerKay Sievers <kay@vrfy.org>2013-01-07 23:48:43 +0100
commit83fdc450aa8f79941bec84488ffd5bf8eadab18e (patch)
tree44e8f381df2d891684ab7b45306314bd762fb783 /configure.ac
parentd0100018c2b03938a2e0821383f578a2372df517 (diff)
bootchart: merge bootchart
Bootchart is renamed to 'systemd-bootchart' and installed as /usr/lib/systemd/systemd-bootchart. The configuration file will reside in /etc/systemd/bootchart.conf.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4a1682741..8a39d9831 100644
--- a/configure.ac
+++ b/configure.ac
@@ -558,6 +558,14 @@ fi
AM_CONDITIONAL(ENABLE_READAHEAD, [test "$have_readahead" = "yes"])
# ------------------------------------------------------------------------------
+have_bootchart=no
+AC_ARG_ENABLE(bootchart, AS_HELP_STRING([--disable-bootchart], [disable bootchart tool]))
+if test "x$enable_bootchart" != "xno"; then
+ have_bootchart=yes
+fi
+AM_CONDITIONAL(ENABLE_BOOTCHART, [test "$have_bootchart" = "yes"])
+
+# ------------------------------------------------------------------------------
have_quotacheck=no
AC_ARG_ENABLE(quotacheck, AS_HELP_STRING([--disable-quotacheck], [disable quotacheck tools]))
if test "x$enable_quotacheck" != "xno"; then
@@ -845,6 +853,7 @@ AC_MSG_RESULT([
binfmt: ${have_binfmt}
vconsole: ${have_vconsole}
readahead: ${have_readahead}
+ bootchart: ${have_bootchart}
quotacheck: ${have_quotacheck}
randomseed: ${have_randomseed}
logind: ${have_logind}