summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWulf C. Krueger <philantrop@exherbo.org>2012-10-06 11:37:44 +0200
committerLennart Poettering <lennart@poettering.net>2012-10-16 02:24:31 +0200
commit78fbaacac004f912ec84b6f57d0bc656c3c95439 (patch)
tree7acff363c8c5250d260f707e52afade226177e3c /configure.ac
parentfd59a381e35edfbeb868143d76181be60df9c22b (diff)
configure.ac: Add a --without-python option.
Being able to be explicit about Python support (in addition to the default of auto-detecting it) and acting upon the result, specifying it as an option gains us more control about both dependencies and the resulting build. Furthermore, relying purely on auto-detection can lead to problems for source-based distros. E. g. systemd being built before *both* 32-bit & 64-bit ABIs are installed will lead to build failures as systemd's build system will pick up either 32-/64-bit Python, conclude both are available and fail if that's not the case.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 19 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index fe8137d81..1bb657d15 100644
--- a/configure.ac
+++ b/configure.ac
@@ -92,19 +92,26 @@ fi
# we use python to build the man page index, and for systemd-python
have_python=no
have_python_devel=no
-AM_PATH_PYTHON(,, [:])
-if test "$PYTHON" != : ; then
- have_python=yes
- AC_PATH_PROG([PYTHON_CONFIG], python-config)
-
- if test -n "$PYTHON_CONFIG" ; then
- have_python_devel=yes
- PYTHON_CFLAGS="`$PYTHON_CONFIG --cflags`"
- PYTHON_LIBS="`$PYTHON_CONFIG --libs`"
- AC_SUBST(PYTHON_CFLAGS)
- AC_SUBST(PYTHON_LIBS)
+
+AC_ARG_WITH([python],
+ [AS_HELP_STRING([--without-python], [Disable building the man page index and systemd-python (default: test)])])
+
+AS_IF([test "x$with_python" != "xno"], [
+ AM_PATH_PYTHON(,, [:])
+ if test "$PYTHON" != : ; then
+ have_python=yes
+ AC_PATH_PROG([PYTHON_CONFIG], python-config)
+
+ if test -n "$PYTHON_CONFIG" ; then
+ have_python_devel=yes
+ PYTHON_CFLAGS="`$PYTHON_CONFIG --cflags`"
+ PYTHON_LIBS="`$PYTHON_CONFIG --libs`"
+ AC_SUBST(PYTHON_CFLAGS)
+ AC_SUBST(PYTHON_LIBS)
+ fi
fi
-fi
+])
+
AM_CONDITIONAL([HAVE_PYTHON], [test "$have_python" = "yes"])
AM_CONDITIONAL([HAVE_PYTHON_DEVEL], [test "$have_python_devel" = "yes"])