summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay@vrfy.org>2012-11-07 14:05:21 +0100
committerKay Sievers <kay@vrfy.org>2012-11-07 14:23:05 +0100
commit448004c340d41f1b7eb3c06cbd694b8862e6524d (patch)
tree75f8b89bb14c9dd35418ec532f8050eb81b3cf8b /Makefile.am
parentc67fbe4c71977de14ebd09a8c250ef8091dff231 (diff)
hwdb: add IEEE OUI data
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e4c7e564f..6c0f0667b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1799,7 +1799,8 @@ dist_udevrules_DATA += \
dist_udevhwdb_DATA = \
hwdb/20-pci-vendor-product.hwdb \
hwdb/20-usb-vendor-product.hwdb \
- hwdb/20-acpi-vendor.hwdb
+ hwdb/20-acpi-vendor.hwdb \
+ hwdb/20-OUI-vendor.hwdb
udevconfdir = $(sysconfdir)/udev
dist_udevconf_DATA = \
@@ -3985,7 +3986,7 @@ distclean-local: $(DISTCLEAN_LOCAL_HOOKS)
clean-local:
rm -rf $(abs_srcdir)/install-tree
- rm -f $(abs_srcdir)/hwdb/usb.ids $(abs_srcdir)/hwdb/pci.ids
+ rm -f $(abs_srcdir)/hwdb/usb.ids $(abs_srcdir)/hwdb/pci.ids $(abs_srcdir)/hwdb/oui.txt
DISTCHECK_CONFIGURE_FLAGS = \
--with-sysvinit-path=$$dc_install_base/$(sysvinitdir) \
@@ -4006,6 +4007,7 @@ hwdb-update:
( cd hwdb && \
wget -N http://www.linux-usb.org/usb.ids && \
wget -N http://pciids.sourceforge.net/v2.2/pci.ids && \
+ wget -N http://standards.ieee.org/develop/regauth/oui/oui.txt && \
./ids-update.pl )
upload: all distcheck