summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/osmesa/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2012-08-22 11:51:31 -0700
committerMatt Turner <mattst88@gmail.com>2012-08-24 11:08:19 -0700
commitdf4dccc7a9691555e05c8945048603621340b5d7 (patch)
treeaef93e5e2e9a72e1f267477fd2be0e608cf9ac49 /src/mesa/drivers/osmesa/Makefile.am
parentc56b57f4a124b218aec21e6a53cd6b5ae1718054 (diff)
build: Only add links to .so files if we're building them
Xlib-GLX and OSMesa support static building. Fixes: https://bugs.freedesktop.org/show_bug.cgi?id=53962
Diffstat (limited to 'src/mesa/drivers/osmesa/Makefile.am')
-rw-r--r--src/mesa/drivers/osmesa/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mesa/drivers/osmesa/Makefile.am b/src/mesa/drivers/osmesa/Makefile.am
index 1ceff886d01..db1d14fe80e 100644
--- a/src/mesa/drivers/osmesa/Makefile.am
+++ b/src/mesa/drivers/osmesa/Makefile.am
@@ -40,12 +40,14 @@ lib@OSMESA_LIB@_la_LIBADD = \
$(top_builddir)/src/mesa/libmesa.la \
$(top_builddir)/src/mapi/glapi/libglapi.la
+if BUILD_SHARED
# Provide compatibility with scripts for the old Mesa build system for
# a while by putting a link to the driver into /lib of the build tree.
all-local: lib@OSMESA_LIB@.la
$(MKDIR_P) $(top_builddir)/$(LIB_DIR);
ln -f .libs/lib@OSMESA_LIB@.so $(top_builddir)/$(LIB_DIR)/lib@OSMESA_LIB@.so;
ln -f .libs/lib@OSMESA_LIB@.so.@VERSION@ $(top_builddir)/$(LIB_DIR)/lib@OSMESA_LIB@.so.@VERSION@;
+endif
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = osmesa.pc