summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-09-24 09:32:56 -0700
committerDylan Baker <dylan@pnwbakers.com>2018-09-24 13:02:07 -0700
commitf03a1605922faffa7773ef991d1f3e207aff6afa (patch)
treee11b6f25a4b9eb58648b4e53e25c55e61fefd7ae /meson.build
parentf2519e3493feb158ded0843ad89ce2ebe9ebae23 (diff)
meson: de-duplicate LLVM check
By adding `_llvm == 'true'` to the required argument we can check the 'auto' and 'true' case in one path. Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build23
1 files changed, 8 insertions, 15 deletions
diff --git a/meson.build b/meson.build
index 7a5bcf9004b..d098f96d949 100644
--- a/meson.build
+++ b/meson.build
@@ -1189,28 +1189,21 @@ endif
_shared_llvm = get_option('shared-llvm')
_llvm = get_option('llvm')
-if _llvm == 'auto'
- dep_llvm = dependency(
- 'llvm',
- version : _llvm_version,
- modules : llvm_modules,
- optional_modules : llvm_optional_modules,
- required : with_amd_vk or with_gallium_radeonsi or with_gallium_swr or with_gallium_opencl,
- static : not _shared_llvm
- )
- with_llvm = dep_llvm.found()
-elif _llvm == 'true'
+dep_llvm = null_dep
+with_llvm = false
+if _llvm != 'false'
dep_llvm = dependency(
'llvm',
version : _llvm_version,
modules : llvm_modules,
optional_modules : llvm_optional_modules,
+ required : (
+ with_amd_vk or with_gallium_radeonsi or with_gallium_swr or
+ with_gallium_opencl or _llvm == 'true'
+ ),
static : not _shared_llvm,
)
- with_llvm = true
-else
- dep_llvm = null_dep
- with_llvm = false
+ with_llvm = dep_llvm.found()
endif
if with_llvm
_llvm_version = dep_llvm.version().split('.')