summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGurkirpal Singh <gurkirpal204@gmail.com>2018-01-20 05:37:53 +0530
committerJulien Isorce <jisorce@oblong.com>2018-03-06 14:29:42 +0000
commite2afa154e99071e8d51be88494cd1347ad113035 (patch)
tree4abe510569a8309ff5b0cddd060941591f42be54 /meson.build
parentbb5e27fab6087a5c1528a5faf507acce700e883c (diff)
st/omx/tizonia: Add --enable-omx-tizonia flag and build files
Allow only bellagio or tizonia to be used at the same time. Detect tizonia package config file Generate libomx_mesa.so and install it to libtizcore.pc::pluginsdir Only compile empty source (target.c) for now. GSoC Project link: https://summerofcode.withgoogle.com/projects/#4737166321123328 Acked-by: Leo Liu <leo.liu@amd.com> Reviewed-by: Julien Isorce <julien.isorce@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9bb114056b1..6a13e800084 100644
--- a/meson.build
+++ b/meson.build
@@ -485,8 +485,15 @@ endif
with_gallium_omx = _omx != 'disabled'
gallium_omx = _omx
dep_omx = []
+dep_omx_other = []
if gallium_omx == 'bellagio'
dep_omx = dependency('libomxil-bellagio')
+elif gallium_omx == 'tizonia'
+ dep_omx = dependency('libtizonia', version : '>= 0.10.0')
+ dep_omx_other = [
+ dependency('libtizplatform'),
+ dependency('tizilheaders')
+ ]
endif
omx_drivers_path = get_option('omx-libs-path')