summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-01-16 10:36:28 -0800
committerDylan Baker <dylan@pnwbakers.com>2018-02-02 11:01:42 -0800
commitd7235ef83b92175537e3b538634ffcff29bf0dce (patch)
tree7bab3c8d00f6e2d50123685ff59e17de6957be50 /meson.build
parent847d0a393d7f0f967f39302900d5330f32b804c8 (diff)
meson: Don't confuse the install and search paths for dri drivers
Currently there is not a separate option for setting the search path of DRI drivers in meson, like there is in scons and autotools. This is an oversight and needs to be fixed. This adds an extra option `dri-search-path`, which will default to the value of `dri-drivers-path`, like autotools does. v2: - Split input list before joining. v3: - use : instead of ; as the delimiter. The autotools help string incorrectly says ; but the code uses : v4: - Take list in pre : delimited form (Ilia) - Ensure that the dri-search-path is absolute when using dri_drivers_path Fixes: db9788420d4bc7b4 ("meson: Add support for configuring dri drivers directory.") Reported-by: Ilia Mirkin <imirkin@alum.mit.edu> Signed-off-by: Dylan Baker <dylan.c.baker@intel.com> Reviewed-by: Eric Anholt <eric@anholt.net> (v2) Reviewed-by: Eric Engestrom <eric@engestrom.ch> (v3)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 80ea60ffa7d..323f7062715 100644
--- a/meson.build
+++ b/meson.build
@@ -57,6 +57,10 @@ dri_drivers_path = get_option('dri-drivers-path')
if dri_drivers_path == ''
dri_drivers_path = join_paths(get_option('libdir'), 'dri')
endif
+dri_search_path = get_option('dri-search-path')
+if dri_search_path == ''
+ dri_search_path = join_paths(get_option('prefix'), dri_drivers_path)
+endif
with_gles1 = get_option('gles1')
with_gles2 = get_option('gles2')