summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBas Nieuwenhuizen <bas@basnieuwenhuizen.nl>2019-06-05 14:34:23 +0200
committerBas Nieuwenhuizen <bas@basnieuwenhuizen.nl>2019-06-13 08:25:48 +0000
commitcb728f28acbf8982d37aa3863cae58db95a439ca (patch)
tree1f85a2195b437d2cfb69f9c9d55da553b6e8d0a6 /meson.build
parentb4c7ce360bc07c507de120d218c7479161c22bc2 (diff)
vl: Always enable drm winsys.
The dri2 winsys also uses libdrm (and you can only enable dri3 if you enable dri2), and the drm winsys only requires libdrm. So if any winsys is enabled you can also enable the drm winsys, and since we always want at least one winsys we can always enable it. I removed the check for the drm platform for VA and OMX since they do not care anymore. Since we still check for one of r600g, nouveau or radeonsi, we are guarantueed to still only enable it by default in a configuration that requires libdrm anyway. So for people using va=auto, we don't suddenly start requiring libdrm were we did not before. This supersedes "vl: Enable DRM by default.", which I pushed, but rolled back because it used dep_libdrm before its definition. Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 0 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index f0fa57ca515..a2978117409 100644
--- a/meson.build
+++ b/meson.build
@@ -503,12 +503,6 @@ if not system_has_kms_drm
else
error('OMX state tracker can only be built on unix-like OSes.')
endif
-elif not (with_platform_x11 or with_platform_drm)
- if ['auto', 'disabled'].contains(_omx)
- _omx = 'disabled'
- else
- error('OMX state tracker requires X11 or drm platform support.')
- endif
elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
if ['auto', 'disabled'].contains(_omx)
_omx = 'disabled'
@@ -589,12 +583,6 @@ if not system_has_kms_drm
else
_va = 'false'
endif
-elif not (with_platform_x11 or with_platform_drm)
- if _va == 'true'
- error('VA state tracker requires X11 or drm or wayland platform support.')
- else
- _va = 'false'
- endif
elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
if _va == 'true'
error('VA state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau.')