summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorVinson Lee <vlee@freedesktop.org>2019-01-26 00:21:06 -0800
committerVinson Lee <vlee@freedesktop.org>2019-01-28 10:47:32 -0800
commitbe5b271ea76d81d32e3dc490ef5b32a61c3fb965 (patch)
tree2f4724857b2bca94440fb5bac0f789b4f2808525 /meson.build
parent7c930d99adfa3537b1dce987178544e1ce5eedf3 (diff)
meson: Fix typo.
meson.build:166:21: ERROR: Unknown method "verson_compare" for a string. Fixes: c1efa240c91e ("meson: Add warnings and errors when using ICC") Signed-off-by: Vinson Lee <vlee@freedesktop.org> Reviewed-by: Caio Marcelo de Oliveira Filho <caio.oliveira@intel.com> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com> Cc: 18.3 <mesa-stable@lists.freedesktop.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 81f50ba6c3c..4a81cd05532 100644
--- a/meson.build
+++ b/meson.build
@@ -162,9 +162,9 @@ with_gallium_virgl = _drivers.contains('virgl')
with_gallium_swr = _drivers.contains('swr')
if cc.get_id() == 'intel'
- if meson.version().verson_compare('< 0.49.0')
+ if meson.version().version_compare('< 0.49.0')
error('Meson does not have sufficient support of ICC before 0.49.0 to compile mesa')
- elif with_gallium_swr and meson.version().verson_compare('== 0.49.0')
+ elif with_gallium_swr and meson.version().version_compare('== 0.49.0')
warning('Meson as of 0.49.0 is sufficient for compiling mesa with ICC, but there are some caveats with SWR. 0.49.1 should resolve all of these')
endif
endif