summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel Stone <daniels@collabora.com>2018-02-27 18:00:23 +0000
committerDaniel Stone <daniels@collabora.com>2018-03-20 16:18:37 +0000
commitbc5e59119ef6e7fdb5b54ce0a690a1ad43e6401c (patch)
treef11662f536d0261aef58539ef73e2e029f02e98b /meson.build
parentd7603cb518cf1e0bf2c07d6ce4b139bf075b3980 (diff)
meson: Don't build svga by default on ARM/AArch64
VMware has no (published) support for Arm-architecture guests. Signed-off-by: Daniel Stone <daniels@collabora.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com> Reported-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 88e90fe8119..24cad58c61e 100644
--- a/meson.build
+++ b/meson.build
@@ -151,7 +151,7 @@ if _drivers == 'auto'
if ['x86', 'x86_64'].contains(host_machine.cpu_family())
_drivers = 'r300,r600,radeonsi,nouveau,virgl,svga,swrast'
elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
- _drivers = 'pl111,vc4,vc5,freedreno,etnaviv,imx,nouveau,tegra,virgl,svga,swrast'
+ _drivers = 'pl111,vc4,vc5,freedreno,etnaviv,imx,nouveau,tegra,virgl,swrast'
else
error('Unknown architecture. Please pass -Dgallium-drivers to set driver options. Patches gladly accepted to fix this.')
endif