summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGurchetan Singh <gurchetansingh@chromium.org>2019-03-15 10:08:45 -0700
committerGurchetan Singh <gurchetansingh@chromium.org>2019-03-21 15:36:39 -0700
commitb07086104533060b833f5d70200dae3c0da6ff7d (patch)
tree3e1309daa8fac86ab2a264f478aef8c4de3e5e2d /meson.build
parentbfed0a7099c2205859f85077976ca143c3c1e840 (diff)
configure.ac / meson: depend on libnativewindow when appropriate
libnativewindow is only available on O or greater, and it's required for some features. Reviewed-by: Tapani Pälli <tapani.palli@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7b337755544..715c966c679 100644
--- a/meson.build
+++ b/meson.build
@@ -726,6 +726,9 @@ if with_platform_android
dependency('hardware'),
dependency('sync'),
]
+ if get_option('platform-sdk-version') >= 26
+ dep_android += dependency('nativewindow')
+ endif
pre_args += '-DHAVE_ANDROID_PLATFORM'
endif
if with_platform_haiku