summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-11-09 13:27:56 -0800
committerDylan Baker <dylan@pnwbakers.com>2018-11-12 08:55:55 -0800
commit9c2a95b29868f1388408b5eb9193fff39f942217 (patch)
treee41183cddb2e4fa58430af9a97b3fc866f41f513 /meson.build
parent4a0c2cfdd64e4755f48e957106374b2a13323bbe (diff)
meson: Don't set -Wall
meson does this for you with its warn levels, so we don't need to set it ourselves. Fixes: d1992255bb29054fa51763376d125183a9f602f3 ("meson: Add build Intel "anv" vulkan driver") Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 18667988bac..dabfb9abddd 100644
--- a/meson.build
+++ b/meson.build
@@ -787,7 +787,7 @@ endif
# Check for generic C arguments
c_args = []
-foreach a : ['-Wall', '-Werror=implicit-function-declaration',
+foreach a : ['-Werror=implicit-function-declaration',
'-Werror=missing-prototypes', '-Werror=return-type',
'-fno-math-errno',
'-fno-trapping-math', '-Qunused-arguments']
@@ -809,7 +809,7 @@ endif
# Check for generic C++ arguments
cpp_args = []
-foreach a : ['-Wall', '-Werror=return-type',
+foreach a : ['-Werror=return-type',
'-fno-math-errno', '-fno-trapping-math',
'-Qunused-arguments']
if cpp.has_argument(a)