summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-11-28 16:42:37 -0800
committerDylan Baker <dylan@pnwbakers.com>2017-12-01 15:31:43 -0800
commit5e71efef44b992b5d70bbc1872ff230ae211141d (patch)
tree445d66212ce1bbc841391a78b1cb49d1d5c148a5 /meson.build
parent7309207432e64678ccde2862040861146e3515d4 (diff)
meson: Add lmsensors support
v2: - Make -Dlmsensors=false work - Simplify auto and true cases Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2115871931d..65c6b98609e 100644
--- a/meson.build
+++ b/meson.build
@@ -926,6 +926,17 @@ if get_option('gallium-extra-hud')
pre_args += '-DHAVE_GALLIUM_EXTRA_HUD=1'
endif
+_sensors = get_option('lmsensors')
+if _sensors != 'false'
+ dep_lmsensors = cc.find_library('libsensors', required : _sensors == 'true')
+ if dep_lmsensors.found()
+ pre_args += '-DHAVE_LIBSENSORS=1'
+ endif
+else
+ dep_lmsensors = []
+endif
+
+
# TODO: nine
# TODO: clover