summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBas Nieuwenhuizen <bas@basnieuwenhuizen.nl>2019-05-30 20:34:06 +0200
committerBas Nieuwenhuizen <bas@basnieuwenhuizen.nl>2019-06-04 20:01:34 +0200
commit392c60928a5debbe6782ed1aa136597504bfbc5b (patch)
tree456d2c4c5dc5d6305bc552aa61454952eee01e42 /meson.build
parentc2a0335bb00e5d33573568aa0e9ad30529da9925 (diff)
vl: Enable DRM by default.
If libdrm is found the pipe loader enables drm anyway, and that is pretty much the only extra dependency this code has. This enables creating libva display using a drm fd without having to enable the DRM (GBM really) backend of EGL, which is completely unrelated. Leaving the X11 platforms alone as they would still result in the additional inclusion of extra deps. Reviewed-by: Marek Olšák <marek.olsak@amd.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index cd994c73b72..1d32d909c95 100644
--- a/meson.build
+++ b/meson.build
@@ -589,9 +589,9 @@ if not system_has_kms_drm
else
_va = 'false'
endif
-elif not (with_platform_x11 or with_platform_drm)
+elif not (with_platform_x11 or dep_libdrm.found())
if _va == 'true'
- error('VA state tracker requires X11 or drm or wayland platform support.')
+ error('VA state tracker requires X11 platform support or libdrm.')
else
_va = 'false'
endif