summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorScott D Phillips <scott.d.phillips@intel.com>2018-02-07 16:55:24 -0800
committerScott D Phillips <scott.d.phillips@intel.com>2018-02-08 11:24:42 -0800
commit1f4d2433e73a0a6d4e2a180de407970d983309db (patch)
treeee69bacbb0af123566f2d2c4320127626cd5cca9 /meson.build
parent464d057c86ab36db81590aa940902ff7e29894da (diff)
meson: Add build option for tools
Add a build option to control building some of the misc tools we have. Also set the executables to install, presumably you want that if you're asking for the build. v2: set 'install:' to the with_tools value, not true (Jordan) handle 'all' in a the comma list (Dylan) Add freedreno's tools (Dylan) Reviewed-by: Eric Anholt <eric@anholt.net> Reviewed-by: Jordan Justen <jordan.l.justen@intel.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b61c285bf00..b39e2f8ab96 100644
--- a/meson.build
+++ b/meson.build
@@ -48,6 +48,10 @@ with_libunwind = get_option('libunwind')
with_asm = get_option('asm')
with_osmesa = get_option('osmesa')
with_swr_arches = get_option('swr-arches').split(',')
+with_tools = get_option('tools').split(',')
+if with_tools.contains('all')
+ with_tools = ['freedreno', 'glsl', 'intel', 'nir', 'nouveau']
+endif
if get_option('texture-float')
pre_args += '-DTEXTURE_FLOAT_ENABLED'
message('WARNING: Floating-point texture enabled. Please consult docs/patents.txt and your lawyer before building mesa.')