summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGreg V <greg@unrelenting.technology>2018-09-16 19:51:51 +0300
committerEric Engestrom <eric.engestrom@intel.com>2019-08-08 21:44:33 +0100
commit0233372581db739a6996d454d8ef4075e3a147c7 (patch)
tree162f8755e7696dd397510eca8bec41f02dac7528 /meson.build
parentc00ee00031dd38a3c12d6661eba5f43d8a422e02 (diff)
util: fix cpuset support on FreeBSD
Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 06953b364a8..5605b92b05d 100644
--- a/meson.build
+++ b/meson.build
@@ -1143,6 +1143,12 @@ if dep_thread.found() and host_machine.system() != 'windows'
args : '-D_GNU_SOURCE')
pre_args += '-DHAVE_PTHREAD_SETAFFINITY'
endif
+ if cc.has_function(
+ 'pthread_setaffinity_np',
+ dependencies : dep_thread,
+ prefix : '#include <pthread_np.h>')
+ pre_args += '-DPTHREAD_SETAFFINITY_IN_NP_HEADER'
+ endif
endif
dep_expat = dependency('expat')
# this only exists on linux so either this is linux and it will be found, or