summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olv@lunarg.com>2011-01-04 01:05:22 +0800
committerChia-I Wu <olv@lunarg.com>2011-01-05 11:37:17 +0800
commitf5c13469320032fe894a95ce493fa64441aa341f (patch)
tree5063340d03003e0a628937ea1c3a7df626b61e70 /configure.ac
parentebcb7f27e5950041478d92c82f0f2419b35cdbd2 (diff)
autoconf: Fix --with-driver=xlib --enable-openvg.
st/egl should be enabled with --enable-openvg even the driver is xlib or osmesa. Also, GLX_DIRECT_RENDERING should not be defined because libdrm is not checked. (cherry picked from commit ada9c78c29ef11720d464211c098b740f8aa11a4)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index bd817753050..b451f7cc169 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1352,7 +1352,7 @@ if test "x$enable_gallium_egl" = xauto; then
enable_gallium_egl=$enable_egl
;;
*)
- enable_gallium_egl=no
+ enable_gallium_egl=$enable_openvg
;;
esac
fi
@@ -1467,10 +1467,6 @@ AC_SUBST([EGL_CLIENT_APIS])
if test "x$HAVE_ST_EGL" = xyes; then
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS egl"
- # define GLX_DIRECT_RENDERING even when the driver is not dri
- if test "x$mesa_driver" != xdri -a "x$driglx_direct" = xyes; then
- DEFINES="$DEFINES -DGLX_DIRECT_RENDERING"
- fi
fi
if test "x$HAVE_ST_XORG" = xyes; then