summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian König <deathsimple@vodafone.de>2010-11-21 19:40:52 +0100
committerChristian König <deathsimple@vodafone.de>2010-11-21 19:40:52 +0100
commite6b71530daea3059ee362d4df51575e27e026b22 (patch)
tree8df01693aa4bf44360647d79a340cbb4156aa91a /configure.ac
parent42c7291d2cb50c2bd94dd9346a8402a24303d66d (diff)
parent5e3733fadf08178fca7c9f20a0f4783f940383aa (diff)
Merge remote branch 'origin/master' into pipe-video
Conflicts: src/gallium/auxiliary/Makefile src/gallium/auxiliary/SConscript
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c172c1cbaed..79e134b4254 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1737,6 +1737,19 @@ if test "x$enable_gallium_swrast" = xyes || test "x$enable_gallium_swrast" = xau
fi
fi
+dnl
+dnl Gallium noop configuration
+dnl
+AC_ARG_ENABLE([gallium-noop],
+ [AS_HELP_STRING([--enable-gallium-noop],
+ [build gallium radeon @<:@default=disabled@:>@])],
+ [enable_gallium_noop="$enableval"],
+ [enable_gallium_noop=auto])
+if test "x$enable_gallium_noop" = xyes; then
+ GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS noop"
+ GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS dri-noop"
+fi
+
dnl prepend CORE_DIRS to SRC_DIRS
SRC_DIRS="$CORE_DIRS $SRC_DIRS"