summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVinson Lee <vlee@freedesktop.org>2013-01-26 22:50:05 -0800
committerVinson Lee <vlee@freedesktop.org>2013-02-09 15:21:08 -0800
commit990bd49fba7d539e950bdda6eb9819a9abf14850 (patch)
tree6b1918892a1b1ffca96bc676530266d345a24291 /configure.ac
parent0e2f26d5ea26febd16173aa8bbf7427b090e320f (diff)
configure.ac: Do not check for rt on Mac OS X.
There is no rt library on Mac OS X. Signed-off-by: Vinson Lee <vlee@freedesktop.org> Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=58872 Acked-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6735fdcf0e2..d08bc2779a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -499,10 +499,16 @@ AC_CHECK_FUNC([dlopen], [DEFINES="$DEFINES -DHAVE_DLOPEN"],
[DEFINES="$DEFINES -DHAVE_DLOPEN"; DLOPEN_LIBS="-ldl"])])
AC_SUBST([DLOPEN_LIBS])
-AC_CHECK_FUNCS([clock_gettime], [CLOCK_LIB=],
- [AC_CHECK_LIB([rt], [clock_gettime], [CLOCK_LIB=-lrt],
- [AC_MSG_ERROR([Couldn't find clock_gettime])])])
-AC_SUBST([CLOCK_LIB])
+case "$host_os" in
+darwin*)
+ ;;
+*)
+ AC_CHECK_FUNCS([clock_gettime], [CLOCK_LIB=],
+ [AC_CHECK_LIB([rt], [clock_gettime], [CLOCK_LIB=-lrt],
+ [AC_MSG_ERROR([Couldn't find clock_gettime])])])
+ AC_SUBST([CLOCK_LIB])
+ ;;
+esac
dnl See if posix_memalign is available
AC_CHECK_FUNC([posix_memalign], [DEFINES="$DEFINES -DHAVE_POSIX_MEMALIGN"])