summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGert Wollny <gw.fossdev@gmail.com>2017-10-18 17:05:27 +0200
committerEmil Velikov <emil.l.velikov@gmail.com>2017-11-08 16:03:38 +0000
commit6905d005ef8a1530ebe851c5a639abd7d22b156b (patch)
treef7bfd0a8864988f5356fccbcabfacc2a6eebac1d /configure.ac
parent8f18528ceade31168be76edbb9fb2c09760fad21 (diff)
clover: use the unified check for c++11 instead of the gcc version number
So far clover based its test for compiler support on the version of gcc, while in reality support for c++11 is required. This patch replaces the version check by the check unified for all modules that require c++11. Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3dd9b9a4ce6..d362dfb15bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2294,8 +2294,8 @@ if test "x$enable_opencl" = xyes; then
AC_MSG_ERROR([cannot enable OpenCL without Gallium])
fi
- if test $GCC_VERSION_MAJOR -lt 4 -o $GCC_VERSION_MAJOR -eq 4 -a $GCC_VERSION_MINOR -lt 7; then
- AC_MSG_ERROR([gcc >= 4.7 is required to build clover])
+ if test "x$HAVE_CXX11" != "xyes"; then
+ AC_MSG_ERROR([clover requires c++11 support])
fi
if test "x$have_libclc" = xno; then