summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@collabora.co.uk>2015-02-22 11:48:24 +0100
committerMiklos Vajna <vmiklos@collabora.co.uk>2015-02-22 17:40:36 +0100
commit4e91003337f8f35810efa00322d041fb4ff94df7 (patch)
tree66f5c77542c25adce98ddb62b0249087069333ac /configure.ac
parent315e72d4300e688e921b1122109dd9a545016feb (diff)
configure: add default value for --with-android-ndk
Change-Id: I2ab9d6fe4ac81f4a102a3f4242aa6d41e81fab88
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a9edea108216..2bd85d5f72d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -294,6 +294,9 @@ AC_ARG_WITH(android-sdk,
,)
ANDROID_NDK_HOME=
+if test -z "$with_android_ndk" -a -e "$SRC_ROOT/external/android-ndk"; then
+ with_android_ndk="$SRC_ROOT/external/android-ndk"
+fi
if test -n "$with_android_ndk"; then
ANDROID_NDK_HOME=$with_android_ndk
@@ -760,7 +763,7 @@ linux-android*)
_os=Android
if test -z "$with_android_ndk"; then
- AC_MSG_ERROR([the --with-android-ndk option is mandatory])
+ AC_MSG_ERROR([the --with-android-ndk option is mandatory, unless it is available at external/android-ndk/.])
fi
if test -z "$with_android_ndk_toolchain_version"; then