summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@collabora.co.uk>2015-02-22 11:48:12 +0100
committerMiklos Vajna <vmiklos@collabora.co.uk>2015-02-22 17:40:36 +0100
commit315e72d4300e688e921b1122109dd9a545016feb (patch)
treea62f658e25dfd5668fadf972d730ab441fea1ff8 /configure.ac
parent9ea95a1dbd7e10343a3549c2cbc1b909a873f5f7 (diff)
configure: add default value for --with-android-sdk
Change-Id: Ib19b57e877c5829dd816d4b4e84bb8f632354789
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a7ad5e1eb946..a9edea108216 100644
--- a/configure.ac
+++ b/configure.ac
@@ -503,9 +503,12 @@ AC_SUBST(ANDROID_NDK_GDBSERVER)
AC_SUBST(ANDROID_APP_ABI)
dnl ===================================================================
-dnl Also --with-android-sdk is mandatory
+dnl --with-android-sdk
dnl ===================================================================
ANDROID_SDK_HOME=
+if test -z "$with_android_sdk" -a -e "$SRC_ROOT/external/android-sdk-linux"; then
+ with_android_sdk="$SRC_ROOT/external/android-sdk-linux"
+fi
if test -n "$with_android_sdk"; then
ANDROID_SDK_HOME=$with_android_sdk
PATH="$ANDROID_SDK_HOME/platform-tools:$ANDROID_SDK_HOME/tools:$PATH"
@@ -780,7 +783,7 @@ esac
if echo "$host_os" | grep -q linux-android ; then
if test -z "$with_android_sdk"; then
- AC_MSG_ERROR([the --with-android-sdk option is mandatory])
+ AC_MSG_ERROR([the --with-android-sdk option is mandatory, unless it is available at external/android-sdk-linux/.])
fi
if test ! -d "$ANDROID_SDK_HOME/platforms"; then