summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2021-02-16 21:33:30 +0100
committerThomas Haller <thaller@redhat.com>2021-02-16 21:54:54 +0100
commitd9968b133b32fbfbc5e726a8fc96e38cc044c831 (patch)
tree25dc7b8c2a652d2ae7d436080e21f29133c4efae /configure.ac
parentcd86b462fc9796882ad58b61079d7bbaf6625ab8 (diff)
build: rename build option "--with-polkit-agent-helper-1{-path,}"
Suggested-by: Michael Biebl <biebl@debian.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2bf5e4e069..39aeea557f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -642,9 +642,9 @@ fi
AC_DEFINE_UNQUOTED(NM_CONFIG_DEFAULT_MAIN_AUTH_POLKIT, "$enable_polkit", [The default value of the auth-polkit configuration option])
AC_SUBST(NM_CONFIG_DEFAULT_MAIN_AUTH_POLKIT_TEXT, "$enable_polkit")
-AC_ARG_WITH([polkit-agent-helper-1-path],
- AS_HELP_STRING([--with-polkit-agent-helper-1-path=PATH],
- [Path name to the polkit-agent-helper-1 binary from polkit]),
+AC_ARG_WITH([polkit-agent-helper-1],
+ AS_HELP_STRING([--with-polkit-agent-helper-1=/path/to/polkit-agent-helper-1],
+ [Path to the polkit-agent-helper-1 binary from polkit]),
POLKIT_AGENT_HELPER_1_PATH="$withval",
POLKIT_AGENT_HELPER_1_PATH="")
if test -z "$POLKIT_AGENT_HELPER_1_PATH" ; then
@@ -658,6 +658,9 @@ if test -z "$POLKIT_AGENT_HELPER_1_PATH" ; then
done
fi
test -z "$POLKIT_AGENT_HELPER_1_PATH" && POLKIT_AGENT_HELPER_1_PATH=/usr/lib/polkit-1/polkit-agent-helper-1
+if test "$POLKIT_AGENT_HELPER_1_PATH" = "${POLKIT_AGENT_HELPER_1_PATH#/}" ; then
+ AC_MSG_ERROR(["polkit_agent_helper_1 must be an absolute path, but is '$POLKIT_AGENT_HELPER_1_PATH'"])
+fi
AC_DEFINE_UNQUOTED([POLKIT_AGENT_HELPER_1_PATH],
["$POLKIT_AGENT_HELPER_1_PATH"],
[path to polkit-agent-helper-1 binary])