summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2018-01-14 14:26:10 +0100
committerThomas Haller <thaller@redhat.com>2018-01-15 20:29:26 +0100
commitd2292cc649ac81a88e0b324d36c47caab30d9ba9 (patch)
tree03b925931f11c3a760a98498c5116befd1042811 /configure.ac
parentcd6116e58f863202a9072b97fc32b1b50f9e1ba3 (diff)
wifi: remove configure checks for suitable WEXT header
The check doesn't seem useful, because it does not result in a fallback or a different build. Just assume <linux/wireless.h> is valid. In case it is not, we will get a build failure later. That is just as good.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 0 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 9008ef88a2..5c694ef84c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -199,25 +199,6 @@ if test x"$ac_with_wext" = x"yes"; then
if test "$enable_wifi" != "yes"; then
AC_MSG_ERROR(Enabling WEXT support and disabling Wi-Fi makes no sense)
fi
- AC_MSG_CHECKING([Linux kernel WEXT headers])
- AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM(
- [[#ifndef __user
- #define __user
- #endif
- #include <sys/types.h>
- #include <linux/types.h>
- #include <sys/socket.h>
- #include <linux/wireless.h>]],
- [[#ifndef IWEVGENIE
- #error "not found"
- #endif]])],
- [ac_have_iwevgenie=yes],
- [ac_have_iwevgenie=no])
- AC_MSG_RESULT($ac_have_iwevgenie)
- if test "$ac_have_iwevgenie" = no; then
- AC_MSG_ERROR(Linux kernel development header linux/wireless.h not installed or not functional)
- fi
AC_DEFINE(HAVE_WEXT, 1, [Define if you have Linux Wireless Extensions support])
else
AC_DEFINE(HAVE_WEXT, 0, [Define if you have Linux Wireless Extensions support])