summaryrefslogtreecommitdiff
path: root/libmm-glib/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libmm-glib/tests/Makefile.am')
-rw-r--r--libmm-glib/tests/Makefile.am24
1 files changed, 17 insertions, 7 deletions
diff --git a/libmm-glib/tests/Makefile.am b/libmm-glib/tests/Makefile.am
index be93d4c6..8984d08d 100644
--- a/libmm-glib/tests/Makefile.am
+++ b/libmm-glib/tests/Makefile.am
@@ -1,12 +1,9 @@
include $(top_srcdir)/gtester.make
-noinst_PROGRAMS = test-common-helpers
-TEST_PROGS += $(noinst_PROGRAMS)
-
-test_common_helpers_SOURCES = \
- test-common-helpers.c
+AM_CFLAGS = $(CODE_COVERAGE_CFLAGS)
+AM_LDFLAGS = $(CODE_COVERAGE_LDFLAGS)
-test_common_helpers_CPPFLAGS = \
+LIBMM_GLIB_TESTS_COMMON_CPPFLAGS = \
$(MM_CFLAGS) \
-I$(top_srcdir) \
-I$(top_srcdir)/include \
@@ -17,6 +14,19 @@ test_common_helpers_CPPFLAGS = \
-I${top_builddir}/libmm-glib/generated \
-DLIBMM_GLIB_COMPILATION
-test_common_helpers_LDADD = \
+LIBMM_GLIB_TESTS_COMMON_LDADD = \
$(top_builddir)/libmm-glib/libmm-glib.la \
$(MM_LIBS)
+
+noinst_PROGRAMS = \
+ test-common-helpers \
+ test-pco
+TEST_PROGS += $(noinst_PROGRAMS)
+
+test_common_helpers_SOURCES = test-common-helpers.c
+test_common_helpers_CPPFLAGS = $(LIBMM_GLIB_TESTS_COMMON_CPPFLAGS)
+test_common_helpers_LDADD = $(LIBMM_GLIB_TESTS_COMMON_LDADD)
+
+test_pco_SOURCES = test-pco.c
+test_pco_CPPFLAGS = $(LIBMM_GLIB_TESTS_COMMON_CPPFLAGS)
+test_pco_LDADD = $(LIBMM_GLIB_TESTS_COMMON_LDADD)