summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2008-08-15 17:50:35 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2008-08-15 17:52:58 +0100
commit8446850029110327be1aa428e393ce238816db08 (patch)
treed91fa1e29aff67e5b95684ecd13bf4947cba302d /Makefile.am
parentbad11b6419d7b1441a5c4091c772d20a46a7fcff (diff)
Set autogen.sh executable, use git in dist-hook, replace _boring with .gitignore
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 77c2b7d63..bdd1018d9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,10 @@ DISTCHECK_CONFIGURE_FLAGS = --disable-debug
dist-hook:
chmod u+w ${distdir}/ChangeLog
- if test -d _darcs; then darcs changes >${distdir}/ChangeLog; fi
+ if test -d ${top_srcdir}/.git; then \
+ git log --stat > ${distdir}/ChangeLog || \
+ git log > ${distdir}/ChangeLog; \
+ fi
check-twisted: all
$(MAKE) -C tests/twisted check-twisted