summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2017-06-20 11:56:07 +0100
committerSimon McVittie <smcv@collabora.com>2017-07-05 16:22:54 +0100
commitbe667087446a08e2074a6e98814fc586a2f07e5a (patch)
treef4fefec00f434c6c9c2f9367bf9b2626d7248cbe /test/Makefile.am
parentaa5fdac60020d3596e3164a40977e90d8f7000c5 (diff)
test-variant: Add a regression test for DBusVariant
Signed-off-by: Simon McVittie <smcv@collabora.com> Reviewed-by: Philip Withnall <withnall@endlessm.com> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=101568
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index ff2fcfe21..fd2fd843b 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -118,6 +118,9 @@ test_refs_LDADD = libdbus-testutils.la $(GLIB_LIBS)
test_syslog_SOURCES = internals/syslog.c
test_syslog_LDADD = libdbus-testutils.la $(GLIB_LIBS)
+test_variant_SOURCES = internals/variant.c
+test_variant_LDADD = libdbus-testutils.la $(GLIB_LIBS)
+
manual_backtrace_SOURCES = manual-backtrace.c
manual_backtrace_LDADD = $(top_builddir)/dbus/libdbus-1.la
@@ -174,6 +177,7 @@ installable_tests += \
test-syntax \
test-syslog \
test-uid-permissions \
+ test-variant \
$(NULL)
if DBUS_UNIX