summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2016-08-12 10:58:13 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2016-08-12 18:13:21 +0100
commit01ffa21501070a26c20f8fe58a9fd7d8c7691b39 (patch)
treeb8f4e21e6cb4cec55f3b69d530336a5188fddc44 /test/Makefile.am
parent53fe3b44af432b7fd19723c74f5282225d24d9fd (diff)
Add a regression test for dbus-launch in X11
Signed-off-by: Simon McVittie <smcv@debian.org> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=97008
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index a588077b2..85799fe3e 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -176,6 +176,7 @@ dist_installable_test_scripts += \
if DBUS_ENABLE_EMBEDDED_TESTS
dist_installable_test_scripts += \
test-dbus-launch-eval.sh \
+ test-dbus-launch-x11.sh \
$(NULL)
endif DBUS_ENABLE_EMBEDDED_TESTS
@@ -200,6 +201,7 @@ installcheck_environment = \
export XDG_RUNTIME_DIR=@abs_top_builddir@/test/XDG_RUNTIME_DIR; \
export DBUS_TEST_DAEMON=$(DESTDIR)$(DBUS_DAEMONDIR)/dbus-daemon$(EXEEXT); \
export DBUS_TEST_DBUS_LAUNCH=$(DESTDIR)$(bindir)/dbus-launch$(EXEEXT); \
+ export DBUS_TEST_DBUS_MONITOR=$(DESTDIR)$(bindir)/dbus-monitor$(EXEEXT); \
export DBUS_TEST_DBUS_SEND=$(DESTDIR)$(bindir)/dbus-send$(EXEEXT); \
export DBUS_TEST_HOMEDIR=@abs_top_builddir@/dbus; \
export DBUS_TEST_DATADIR=$(DESTDIR)$(datadir); \
@@ -210,6 +212,7 @@ AM_TESTS_ENVIRONMENT = \
export DBUS_FATAL_WARNINGS=1; \
export DBUS_TEST_DAEMON=@abs_top_builddir@/bus/dbus-daemon$(EXEEXT); \
export DBUS_TEST_DBUS_LAUNCH=@abs_top_builddir@/tools/dbus-launch$(EXEEXT); \
+ export DBUS_TEST_DBUS_MONITOR=@abs_top_builddir@/tools/dbus-monitor$(EXEEXT); \
export DBUS_TEST_DBUS_SEND=@abs_top_builddir@/tools/dbus-send$(EXEEXT); \
export DBUS_TEST_DATA=@abs_top_builddir@/test/data; \
export DBUS_TEST_HOMEDIR=@abs_top_builddir@/dbus; \