summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 4748724e3..6a671587e 100644
--- a/meson.build
+++ b/meson.build
@@ -369,8 +369,15 @@ elif get_option('dga') == 'true'
build_dga = true
endif
-# XXX: Allow configuration of these.
build_apm = false
+if (get_option('linux_apm') == true and
+ host_machine.system() == 'linux')
+ if cc.has_header('linux/apm_bios.h')
+ build_apm = true
+ endif
+endif
+
+# XXX: Allow configuration of these.
build_acpi = false
build_mitshm = true
build_xselinux = false