summaryrefslogtreecommitdiff
path: root/Xext/Makefile.am
diff options
context:
space:
mode:
authorOlivier Fourdan <ofourdan@redhat.com>2016-02-10 09:34:34 +0100
committerAdam Jackson <ajax@redhat.com>2016-02-29 16:29:01 -0500
commitf175cf45aebcdda53f3ae49c0eaf27da1f194e92 (patch)
treeca17946779ca899fd75cfa036e3f8b9e85ce65de /Xext/Makefile.am
parent17097e083b2392c8989474f6e0da8cc234329e9c (diff)
vidmode: move to a separate library of its own
XVidMode extension might be useful to non hardware servers as well (e.g. Xwayand) so that applications that rely on it (e.g. lot of older games) can at least have read access to XVidMode. But the implementation is very XFree86 centric, so the idea is to add a bunch of vfunc that other non-XFree86 servers can hook up into to provide a similar functionality. Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=87806 Reviewed-by: Adam Jackson <ajax@redhat.com> Signed-off-by: Olivier Fourdan <ofourdan@redhat.com>
Diffstat (limited to 'Xext/Makefile.am')
-rw-r--r--Xext/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Xext/Makefile.am b/Xext/Makefile.am
index a9a446820..1ceb9803d 100644
--- a/Xext/Makefile.am
+++ b/Xext/Makefile.am
@@ -1,4 +1,4 @@
-noinst_LTLIBRARIES = libXext.la libXextdpmsstubs.la
+noinst_LTLIBRARIES = libXext.la libXextdpmsstubs.la libXvidmode.la
AM_CFLAGS = $(DIX_CFLAGS)
@@ -6,7 +6,7 @@ if XORG
sdk_HEADERS = xvdix.h xvmcext.h geext.h geint.h shmint.h syncsdk.h
endif
-# Sources always included in libXextbuiltin.la & libXext.la
+# Sources always included in libXextbuiltin.la, libXext.la
BUILTIN_SRCS = \
bigreq.c \
geext.c \
@@ -98,6 +98,9 @@ libXext_la_LIBADD = $(BUILTIN_LIBS)
libXextdpmsstubs_la_SOURCES = dpmsstubs.c
+# XVidMode extension
+libXvidmode_la_SOURCES = vidmode.c
+
EXTRA_DIST = \
$(MITSHM_SRCS) \
$(XV_SRCS) \