summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSoren Sandmann Pedersen <ssp@dhcp83-218.boston.redhat.com>2007-05-15 11:08:24 -0400
committerSoren Sandmann Pedersen <ssp@dhcp83-218.boston.redhat.com>2007-05-15 11:08:24 -0400
commitffbb4a6b1fb52dc46639d18bf0dd769fe53d3e88 (patch)
tree5b778deb7ea09b318cafa03a1a24878e7c658ae2 /test/Makefile.am
parentb8d223d6837d37bc09efdf3c4d957ff24337004a (diff)
Don't build GTK+ test programs if GTK+ is not available
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index fedbcdc..6389b5b 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,14 +1,13 @@
+if HAVE_GTK
TESTPROGRAMS = \
composite-test \
gradient-test
noinst_PROGRAMS = $(TESTPROGRAMS)
-INCLUDES = -I$(top_srcdir)/pixman `pkg-config --cflags gtk+-2.0`
-
-GTKLIBS = -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpng12 -lm -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
-
-composite_test_LDADD = $(top_builddir)/pixman/libpixman.la $(GTKLIBS)
-gradient_test_LDADD = $(top_builddir)/pixman/libpixman.la $(GTKLIBS)
+INCLUDES = -I$(top_srcdir)/pixman $(GTK_CFLAGS)
+composite_test_LDADD = $(top_builddir)/pixman/libpixman.la $(GTK_LIBS)
+gradient_test_LDADD = $(top_builddir)/pixman/libpixman.la $(GTK_LIBS)
+endif \ No newline at end of file