summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2008-09-06 23:49:25 -0400
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2008-09-06 23:49:25 -0400
commit00f3d6ef22b5a062323208fd540a17ca65dca42b (patch)
tree9a405e31aaa3a1575e31bb1109195b1a38c08392 /test/Makefile.am
parentd5b4fd7e11c2f2b2e8ab3cb95bef252ce142982e (diff)
Fix bug in pixman_image_is_opaque()
Non-repeating gradient images would be reported as opaque. Also add new test program to test source clipping.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index ced0579..33e2200 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,5 +1,6 @@
if HAVE_GTK
-TESTPROGRAMS = \
+TESTPROGRAMS = \
+ clip-test \
composite-test \
gradient-test \
region-test \
@@ -13,5 +14,6 @@ composite_test_LDADD = $(top_builddir)/pixman/libpixman-1.la $(GTK_LIBS)
gradient_test_LDADD = $(top_builddir)/pixman/libpixman-1.la $(GTK_LIBS)
fetch_test_LDADD = $(top_builddir)/pixman/libpixman-1.la
region_test_LDADD = $(top_builddir)/pixman/libpixman-1.la
+clip_test_LDADD = $(top_builddir)/pixman/libpixman-1.la $(GTK_LIBS)
endif