summaryrefslogtreecommitdiff
path: root/test/xi2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/xi2/Makefile.am')
-rw-r--r--test/xi2/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/xi2/Makefile.am b/test/xi2/Makefile.am
index 0185c311b..e9f9a06e5 100644
--- a/test/xi2/Makefile.am
+++ b/test/xi2/Makefile.am
@@ -1,6 +1,17 @@
if UNITTESTS
+check_PROGRAMS = \
+ protocol-xiqueryversion
+
+TESTS=$(check_PROGRAMS)
+
AM_CFLAGS = $(DIX_CFLAGS) $(GLIB_CFLAGS) @XORG_CFLAGS@
INCLUDES = @XORG_INCS@
TEST_LDADD=../libxservertest.la $(XORG_SYS_LIBS) $(XSERVER_SYS_LIBS) $(GLIB_LIBS)
COMMON_SOURCES=protocol-common.h protocol-common.c
+
+protocol_xiqueryversion_LDADD=$(TEST_LDADD)
+
+protocol_xiqueryversion_CFLAGS=$(AM_CFLAGS) -Wl,-wrap,WriteToClient
+
+protocol_xiqueryversion_SOURCES=$(COMMON_SOURCES) protocol-xiqueryversion.c
endif