summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2012-01-30 14:04:04 +0100
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2012-04-06 14:01:19 +0200
commitbfeda130de340c090895d23ea0a5742521ff0078 (patch)
tree4b989a3e5e1472b644f690be28cc519666810d62 /src/Makefile.am
parent1a36156972f14bb8d481abd71cb4210eb226a7ba (diff)
Introduce weston-launchweston-launch-final
weston-launch starts weston and provides mechanism for weston to set/drop drm master, open a tty, and read input devices without being root. Execution is allowed for local-active sessions or users in the group weston-launch.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 048e58f..c9fdc5a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,5 @@
-bin_PROGRAMS = weston
+bin_PROGRAMS = weston \
+ $(weston_launch)
AM_CPPFLAGS = \
-DDATADIR='"$(datadir)"' \
@@ -22,14 +23,33 @@ weston_SOURCES = \
util.c \
matrix.c \
matrix.h \
+ weston-launch.h \
$(xserver_launcher_sources)
+if BUILD_WESTON_LAUNCH
+weston_launch = weston-launch
+weston_launch_SOURCES = weston-launch.c weston-launch.h
+weston_launch_CFLAGS= $(GCC_CFLAGS)
+weston_launch_CPPFLAGS = $(WESTON_LAUNCH_CFLAGS) $(SYSTEMD_LOGIN_CFLAGS) \
+ -DBINDIR='"$(bindir)"'
+weston_launch_LDADD = $(WESTON_LAUNCH_LIBS) $(SYSTEMD_LOGIN_LIBS)
+
+if ENABLE_SETUID_INSTALL
+install-exec-hook:
+ chown root $(DESTDIR)$(bindir)/weston-launch
+ chmod u+s $(DESTDIR)$(bindir)/weston-launch
+endif
+
+else # BUILD_WESTON_LAUNCH
+
if ENABLE_SETUID_INSTALL
install-exec-hook:
chown root $(DESTDIR)$(bindir)/weston
chmod u+s $(DESTDIR)$(bindir)/weston
endif
+endif # BUILD_WESTON_LAUNCH
+
if ENABLE_XSERVER_LAUNCHER
xserver_launcher_sources = \
xserver-launcher.c \
@@ -67,6 +87,8 @@ drm_backend_la_SOURCES = \
tty.c \
evdev.c \
evdev.h \
+ launcher-util.c \
+ launcher-util.h \
libbacklight.c \
libbacklight.h
endif