summaryrefslogtreecommitdiff
path: root/clients/Makefile.am
diff options
context:
space:
mode:
authorPekka Paalanen <ppaalanen@gmail.com>2011-12-05 15:58:11 +0200
committerPekka Paalanen <ppaalanen@gmail.com>2011-12-08 10:25:12 +0200
commitc1765c67b394ec82c5d576140e0e297088deaabb (patch)
treec1dbd63e13f96c3061b79054f246a601d1bb0d73 /clients/Makefile.am
parent02dfb7514547e48045e20ed57f361cfc7826ada3 (diff)
move config parser to a convenience library
Create a new directory for convenience librariers that can be shared between compositor components and clients. Signed-off-by: Pekka Paalanen <ppaalanen@gmail.com>
Diffstat (limited to 'clients/Makefile.am')
-rw-r--r--clients/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/clients/Makefile.am b/clients/Makefile.am
index e2521d9..0494c3b 100644
--- a/clients/Makefile.am
+++ b/clients/Makefile.am
@@ -40,8 +40,7 @@ libtoytoolkit_a_SOURCES = \
window.c \
window.h \
cairo-util.c \
- cairo-util.h \
- config.c
+ cairo-util.h
toolkit_libs = \
libtoytoolkit.a \
@@ -81,13 +80,15 @@ wayland_desktop_shell_SOURCES = \
desktop-shell.c \
desktop-shell-client-protocol.h \
desktop-shell-protocol.c
-wayland_desktop_shell_LDADD = $(toolkit_libs)
+wayland_desktop_shell_LDADD = $(toolkit_libs) \
+ ../shared/libconfigparser.la
wayland_tablet_shell_SOURCES = \
tablet-shell.c \
tablet-shell-client-protocol.h \
tablet-shell-protocol.c
-wayland_tablet_shell_LDADD = $(toolkit_libs)
+wayland_tablet_shell_LDADD = $(toolkit_libs) \
+ ../shared/libconfigparser.la
BUILT_SOURCES = \
screenshooter-client-protocol.h \