summaryrefslogtreecommitdiff
path: root/src/egl/eglut/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/egl/eglut/Makefile.am')
-rw-r--r--src/egl/eglut/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/egl/eglut/Makefile.am b/src/egl/eglut/Makefile.am
index f0ab2832..213f8925 100644
--- a/src/egl/eglut/Makefile.am
+++ b/src/egl/eglut/Makefile.am
@@ -29,8 +29,20 @@ if HAVE_EGL
if HAVE_X11
eglut_x11 = libeglut_x11.la
endif
-noinst_LTLIBRARIES = libeglut_screen.la $(eglut_x11)
+if HAVE_WAYLAND
+eglut_wayland = libeglut_wayland.la
endif
+noinst_LTLIBRARIES = libeglut_screen.la $(eglut_x11) $(eglut_wayland)
+endif
+
+libeglut_wayland_la_SOURCES= \
+ eglut.c \
+ eglut.h \
+ eglutint.h \
+ eglut_wayland.c
+
+libeglut_wayland_la_CFLAGS = $(WAYLAND_CFLAGS) $(EGL_CFLAGS)
+libeglut_wayland_la_LIBADD = $(WAYLAND_LIBS) $(EGL_LIBS)
libeglut_screen_la_SOURCES = \
eglut.c \