summaryrefslogtreecommitdiff
path: root/hw/xfree86/os-support/Makefile.am
diff options
context:
space:
mode:
authorKevin E Martin <kem@kem.org>2005-07-15 22:51:05 +0000
committerKevin E Martin <kem@kem.org>2005-07-15 22:51:05 +0000
commita407fa373bb72f29050e3f027042011075b3bdf0 (patch)
tree002e232489505a0ca8e4b3e7b2862b748c21dfa3 /hw/xfree86/os-support/Makefile.am
parenteb6fa0dc15516a0a436090efc6d85f22baeec015 (diff)
Move drm up to os-support since the files are shared by multiple platforms.
Fix the dri and drm build. Fix server-side DMX extension build. Make xf4bpp use the correct version of mfbline.c for mfbseg.c. Add #ifndef _HEADERNAME_H_/#define _HEADERNAME_H_/.../#endif to the headers.
Diffstat (limited to 'hw/xfree86/os-support/Makefile.am')
-rw-r--r--hw/xfree86/os-support/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/hw/xfree86/os-support/Makefile.am b/hw/xfree86/os-support/Makefile.am
index b55e9786d..b83ae9142 100644
--- a/hw/xfree86/os-support/Makefile.am
+++ b/hw/xfree86/os-support/Makefile.am
@@ -1,4 +1,8 @@
-SUBDIRS = bus @XORG_OS_SUBDIR@ misc
+if DRI
+DRI_SUBDIRS=drm
+endif
+
+SUBDIRS = bus @XORG_OS_SUBDIR@ misc $(DRI_SUBDIRS)
sdk_HEADERS = xf86_OSproc.h xf86_OSlib.h xf86_ansic.h xf86_libc.h xf86drm.h \
xf86drmCompat.h assyntax.h xf86OSKbd.h xf86OSmouse.h