summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2016-05-26 10:20:45 -0700
committerAdam Jackson <ajax@redhat.com>2016-07-21 15:04:47 -0400
commitd6eff3c31e8289881a3aa9b858e5710d0f741db0 (patch)
tree4770bb14529c4b7dd1764b58cd2f2deb59efe7c9 /configure.ac
parentd403aca70a07e1401cb93738f1af5961582a2e47 (diff)
os: Add ospoll interface [v2]
This provides a wrapper around poll or epoll providing a callback-based interface for monitoring activity on a large set of file descriptors. v2: use xserver_poll API instead of poll. Don't use WSAPoll as that is broken. Signed-off-by: Keith Packard <keithp@keithp.com> Reviewed-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 58fcf79d5..2b93a4a30 100644
--- a/configure.ac
+++ b/configure.ac
@@ -219,7 +219,7 @@ dnl Checks for library functions.
AC_CHECK_FUNCS([backtrace ffs geteuid getuid issetugid getresuid \
getdtablesize getifaddrs getpeereid getpeerucred getprogname getzoneid \
mmap posix_fallocate seteuid shmctl64 strncasecmp vasprintf vsnprintf \
- walkcontext setitimer poll])
+ walkcontext setitimer poll epoll_create1])
AC_CONFIG_LIBOBJ_DIR([os])
AC_REPLACE_FUNCS([reallocarray strcasecmp strcasestr strlcat strlcpy strndup])
AM_CONDITIONAL(POLL, [test "x$ac_cv_func_poll" = "xyes"])