summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2018-08-01 13:49:52 -0700
committerAdam Jackson <ajax@redhat.com>2018-08-02 10:27:37 -0400
commitaccd32a466a1a87ab45b5422dff2ef5a9c867049 (patch)
treed6e96295a5f9445553530673638134f4a6d046a3 /configure.ac
parent708ddfbda1391468d66957e247f51854b39db5fa (diff)
xorg: Remove the XF86PM define.
We already have pm_noop.c being built most of the time for the no-OS-PM case, so just switch to always using it. Signed-off-by: Eric Anholt <eric@anholt.net> Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index e0ebc78a1..350c89a3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1915,9 +1915,6 @@ if test "x$XORG" = xyes; then
esac
dnl APM header
AC_CHECK_HEADERS([linux/apm_bios.h], [linux_apm=$enable_linux_apm])
- if test "x$linux_apm" = xyes -o "x$linux_acpi" = xyes; then
- AC_DEFINE(XF86PM, 1, [Support APM/ACPI power management in the server])
- fi
;;
freebsd* | kfreebsd*-gnu | dragonfly*)
XORG_OS_SUBDIR="bsd"
@@ -1926,15 +1923,10 @@ if test "x$XORG" = xyes; then
XORG_OS_SUBDIR="bsd"
;;
openbsd*)
- if test "x$ac_cv_BSD_APM" = xyes \
- -o "x$ac_cv_BSD_KQUEUE_APM" = xyes; then
- XORG_CFLAGS="$XORG_CFLAGS -DXF86PM"
- fi
XORG_OS_SUBDIR="bsd"
;;
solaris*)
XORG_OS_SUBDIR="solaris"
- XORG_CFLAGS="$XORG_CFLAGS -DXF86PM"
AC_CHECK_HEADERS([sys/kd.h])
AC_CHECK_HEADERS([sys/vt.h], [solaris_vt=yes], [solaris_vt=no])
# Check for minimum supported release