summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMihail Konev <k.mvc@ya.ru>2016-10-14 02:40:59 +0000
committerAdam Jackson <ajax@redhat.com>2016-10-26 12:40:14 -0400
commit8fee6a917b6468e1b116d922f86484498874fb5c (patch)
tree5e04d2de9642b17439ac4ebc1f598f7afd46cee4 /configure.ac
parentd13cb974426f7f1110b0bdb08c4ebb46ff8975f7 (diff)
xwin: make glx optional again
Commit 501d8e2b removed --enable-aiglx, but made xwin always be --enable-glx. Signed-off-by: Mihail Konev <k.mvc@ya.ru> Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Jon Turney <jon.turney@dronecode.org.uk> Signed-off-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4bb014d0d..25168cc67 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2233,7 +2233,7 @@ if test "x$XWIN" = xyes; then
AC_DEFINE(DDXBEFORERESET, 1, [Use ddxBeforeReset ])
dnl XWin requires OpenGL spec files in order to generate wrapper code for native GL functions
- if [test "x$XWIN" = xyes] ; then
+ if [test "x$XWIN" = xyes && test "x$GLX" = xyes] ; then
AC_CHECK_PROG(PYTHON3, python3, python3)
if test -z "$PYTHON3"; then
AC_MSG_ERROR([python3 not found])
@@ -2256,7 +2256,7 @@ AM_CONDITIONAL(XWIN, [test "x$XWIN" = xyes])
AM_CONDITIONAL(XWIN_MULTIWINDOW, [test "x$XWIN" = xyes])
AM_CONDITIONAL(XWIN_MULTIWINDOWEXTWM, [test "x$XWIN" = xyes && test "x$WINDOWSWM" = xyes])
AM_CONDITIONAL(XWIN_CLIPBOARD, [test "x$XWIN" = xyes])
-AM_CONDITIONAL(XWIN_GLX_WINDOWS, [test "x$XWIN" = xyes])
+AM_CONDITIONAL(XWIN_GLX_WINDOWS, [test "x$XWIN" = xyes && test "x$GLX" = xyes])
AM_CONDITIONAL(XWIN_WINDOWS_DRI, [test "x$XWIN" = xyes && test "x$WINDOWSDRI" = xyes])
AM_CONDITIONAL(XWIN_RANDR, [test "x$XWIN" = xyes])
AM_CONDITIONAL(XWIN_XV, [test "x$XWIN" = xyes && test "x$XV" = xyes])