summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOlivier Fourdan <ofourdan@redhat.com>2020-10-27 16:33:55 +0100
committerOlivier Fourdan <fourdan@gmail.com>2020-11-09 09:38:46 +0000
commit899cebb76ab7754fea49f7babcd64a7e94052cc8 (patch)
tree081e1bf02048f2f169d57ac3311b1e3dfdbcb3f0 /configure.ac
parent606ba7fc51e5420646f75c4e672fbe61eb7c7e6e (diff)
configure: Build hashtable for Xres and glvnd
With autoconf, hashtable support is built along with Xres support. Yet, glvnd also use it, so when disabling Xres from configure, the build will fail at link time because hashtable functions are not available. Untie the build of hashtable from Xres support, just like meson build does. Signed-off-by: Olivier Fourdan <ofourdan@redhat.com> Closes: https://gitlab.freedesktop.org/xorg/xserver/-/issues/1091
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2f2c1cd53..1333584c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1056,9 +1056,11 @@ if test "x$SCREENSAVER" = xyes; then
SDK_REQUIRED_MODULES="$SDK_REQUIRED_MODULES $SCRNSAVERPROTO"
fi
+HASHTABLE=no
AM_CONDITIONAL(RES, [test "x$RES" = xyes])
if test "x$RES" = xyes; then
AC_DEFINE(RES, 1, [Support X resource extension])
+ HASHTABLE=yes
REQUIRED_MODULES="$REQUIRED_MODULES $RESOURCEPROTO"
SDK_REQUIRED_MODULES="$SDK_REQUIRED_MODULES $RESOURCEPROTO"
fi
@@ -1242,6 +1244,7 @@ if test "x$GLX" = xyes; then
PKG_CHECK_MODULES([GL], $GLPROTO $LIBGL)
AC_SUBST(XLIB_CFLAGS)
AC_DEFINE(GLXEXT, 1, [Build GLX extension])
+ HASHTABLE=yes
GLX_LIBS='$(top_builddir)/glx/libglx.la $(top_builddir)/glx/libglxvnd.la'
GLX_SYS_LIBS="$GLX_SYS_LIBS $GL_LIBS"
else
@@ -1249,6 +1252,8 @@ else
fi
AM_CONDITIONAL(GLX, test "x$GLX" = xyes)
+AM_CONDITIONAL(HASHTABLE, test "x$HASHTABLE" = xyes)
+
AC_SUBST([GLX_DEFINES])
AC_SUBST([GLX_SYS_LIBS])