summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdam Jackson <ajax@redhat.com>2016-06-29 14:07:32 -0400
committerAdam Jackson <ajax@redhat.com>2016-06-30 13:12:08 -0400
commit3762edded8e6e973f71419937e16bea262a266b8 (patch)
tree5eb59a33468d9370061d396325b0c6fdd8a004fc /configure.ac
parentd135100d6b17e54262a12aeaebe0fe2fe48da3bb (diff)
configure: Tell AC_REPLACE_FUNCS where to find replacements
Fixes weird link errors of the form: CCLD Xvfb ../../Xext/.libs/libXext.a(xvmc.o): In function `xf86XvMCRegisterDRInfo': /home/ajax/git/xserver/Xext/xvmc.c:828: undefined reference to `strlcpy' /home/ajax/git/xserver/Xext/xvmc.c:829: undefined reference to `strlcpy' ../../os/os.O: In function `siHostnameAddrMatch': /home/ajax/git/xserver/os/access.c:1821: undefined reference to `strlcpy' ../../os/os.O: In function `AuthAudit': /home/ajax/git/xserver/os/connection.c:555: undefined reference to `strlcpy' /home/ajax/git/xserver/os/connection.c:574: undefined reference to `strlcpy' ../../os/os.O:/home/ajax/git/xserver/os/log.c:972: more undefined references to `strlcpy' follow collect2: error: ld returned 1 exit status Makefile:688: recipe for target 'Xvfb' failed make[3]: *** [Xvfb] Error 1 Makefile:749: recipe for target 'all-recursive' failed make[2]: *** [all-recursive] Error 1 Makefile:608: recipe for target 'all-recursive' failed make[1]: *** [all-recursive] Error 1 Makefile:776: recipe for target 'all-recursive' failed make: *** [all-recursive] Error 1 Signed-off-by: Adam Jackson <ajax@redhat.com> Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f14e08853..560d38227 100644
--- a/configure.ac
+++ b/configure.ac
@@ -220,6 +220,7 @@ AC_CHECK_FUNCS([backtrace ffs geteuid getuid issetugid getresuid \
getdtablesize getifaddrs getpeereid getpeerucred getprogname getzoneid \
mmap posix_fallocate seteuid shmctl64 strncasecmp vasprintf vsnprintf \
walkcontext setitimer])
+AC_CONFIG_LIBOBJ_DIR([os])
AC_REPLACE_FUNCS([reallocarray strcasecmp strcasestr strlcat strlcpy strndup])
AC_CHECK_DECLS([program_invocation_short_name], [], [], [[#include <errno.h>]])