summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2019-09-23 18:23:40 +0300
committerAdam Jackson <ajax@nwnk.net>2019-10-29 20:45:15 +0000
commit334f1107146a2e6ebf6f7743b77aec2ad5c46f75 (patch)
tree53b9798f7735f9ecfa031dccc110b3e4e2c0b883 /configure.ac
parenta1e3dfa50a9a9a41c93c12f19f40d97c56ddf850 (diff)
configure: Set libdrm flags correctly if only XORG is enabled
This fixes modesetting driver build failure which can be triggered with the following configure options: $ ./configure --disable-dri --disable-dri2 --disable-dri3 --disable-config-udev --enable-xorg Bugzilla: https://bugs.gentoo.org/689768 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 969090b94..268c82fda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1237,7 +1237,7 @@ esac
AM_CONDITIONAL(DRI3, test "x$DRI3" = xyes)
-if test "x$DRI" = xyes || test "x$DRI2" = xyes || test "x$DRI3" = xyes || test "x$CONFIG_UDEV_KMS" = xyes; then
+if test "x$DRI" = xyes || test "x$DRI2" = xyes || test "x$DRI3" = xyes || test "x$CONFIG_UDEV_KMS" = xyes || test "x$XORG" = xyes; then
if test "x$DRM" = xyes; then
AC_DEFINE(WITH_LIBDRM, 1, [Building with libdrm support])
PKG_CHECK_MODULES([LIBDRM], $LIBDRM)