summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJon Turney <jon.turney@dronecode.org.uk>2016-07-28 14:26:38 +0100
committerJon Turney <jon.turney@dronecode.org.uk>2019-05-18 14:59:38 +0000
commit246b729df87e94e405a8b257f34a22fa2719d30c (patch)
tree25cea0489755db2259253393cf28def6ecfb3279 /configure.ac
parent29a8baa031a87ef44d1e5320ecec5015d26fd385 (diff)
configure: Force --disable-input-thread for MinGW
I don't think an input thread can ever be useful on Windows. There is a pthread emulation, so having the thread itself isn't much of a problem. However, there is no device to wait on for Windows events, and even if we were to replace select() with WFMO, Windows wants to send events for a window to the thread which created that window. So, disable input thread by default for MinGW v2: Also add similar to meson.build
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5055d271d..215dd64fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -791,6 +791,11 @@ if test "x$HAVE_RECURSIVE_MUTEX" = "xyes" ; then
THREAD_DEFAULT=yes
fi
+case $host_os in
+ mingw*) THREAD_DEFAULT=no ;;
+ *)
+esac
+
AC_ARG_ENABLE(input-thread, AS_HELP_STRING([--enable-input-thread],
[Enable input threads]),
[INPUTTHREAD=$enableval], [INPUTTHREAD=$THREAD_DEFAULT])