summaryrefslogtreecommitdiff
path: root/hw/xfree86/scanpci/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xfree86/scanpci/Makefile.am')
-rw-r--r--hw/xfree86/scanpci/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/hw/xfree86/scanpci/Makefile.am b/hw/xfree86/scanpci/Makefile.am
new file mode 100644
index 000000000..f52d91b61
--- /dev/null
+++ b/hw/xfree86/scanpci/Makefile.am
@@ -0,0 +1,19 @@
+module_LTLIBRARIES = libscanpci.la libpcidata.la
+
+libpcidata_la_SOURCES = xf86PciData.c
+libscanpci_la_SOURCES = xf86ScanPci.c
+
+INCLUDES = $(XORG_INCS)
+
+EXTRA_DIST = \
+ xf86PciData.h \
+ xf86PciIds.h \
+ xf86PciStdIds.h \
+ xf86PciStr.h \
+ xf86ScanPci.h
+
+xf86PciData.c:
+ echo "#define PCIDATA" > $@
+ echo "#include \"$(srcdir)/xf86ScanPci.c\"" >> $@
+
+DISTCLEANFILES = xf86PciData.c