summaryrefslogtreecommitdiff
path: root/hw/xfree86/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2007-08-31 12:24:07 -0700
committerEric Anholt <eric@anholt.net>2007-08-31 13:09:45 -0700
commita02db0d500cac20d0f0f107d27c064a175018421 (patch)
tree2530044e3e5c99afa615b464c52c8a0e1219a3d9 /hw/xfree86/Makefile.am
parent3f42af8c0ef1e5379bc836f589e0cbee43c02ac5 (diff)
Convert servers to using _DEPENDENCIES to ensure proper rebuilds.
This cleans up server Makefile.ams a little bit, but also means that people messing with configure.ac need to be careful with whether they put libraries in the _LIBS or _SYS_LIBS targets. Hopefully the comment in configure.ac will clarify the issues.
Diffstat (limited to 'hw/xfree86/Makefile.am')
-rw-r--r--hw/xfree86/Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/hw/xfree86/Makefile.am b/hw/xfree86/Makefile.am
index 3ba6adc16..511e224d3 100644
--- a/hw/xfree86/Makefile.am
+++ b/hw/xfree86/Makefile.am
@@ -48,7 +48,7 @@ osandcommon.c xorg.c:
DISTCLEANFILES = osandcommon.c xorg.c
XORG_LIBS = \
- @XORG_CORE_LIBS@ \
+ $(XSERVER_LIBS \
common/libinit.a \
loader/libloader.a \
libosandcommon.la \
@@ -59,14 +59,11 @@ XORG_LIBS = \
ramdac/libramdac.a \
ddc/libddc.a \
i2c/libi2c.a \
+ dixmods/libxorgxkb.la \
@XORG_LIBS@
-Xorg_DEPENDENCIES = \
- $(XORG_LIBS)
-
-Xorg_LDADD = $(XORG_LIBS) \
- @XSERVER_LIBS@ \
- dixmods/libxorgxkb.la
+Xorg_DEPENDENCIES = $(XORG_LIBS)
+Xorg_LDADD = $(XORG_LIBS) $(XORG_SYS_LIBS) $(XSERVER_SYS_LIBS)
Xorg_LDFLAGS = $(LD_EXPORT_SYMBOLS_FLAG)