summaryrefslogtreecommitdiff
path: root/hw/xfree86/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-07-12 13:00:32 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-07-12 13:00:32 -0700
commit9fcb30ebf7b7b2137955f759e95c1d58c4f27a11 (patch)
tree6c25ff1c35b499a6350bfa9214b104ec209fdefe /hw/xfree86/Makefile.am
parent7c0ca27f6dd0a800dc27429a33dbc8e133f9a9c1 (diff)
Make SOLARIS_INOUT_ARCH substitutions work better with automake-1.10
Diffstat (limited to 'hw/xfree86/Makefile.am')
-rw-r--r--hw/xfree86/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/hw/xfree86/Makefile.am b/hw/xfree86/Makefile.am
index 50aa67341..cef6b5be2 100644
--- a/hw/xfree86/Makefile.am
+++ b/hw/xfree86/Makefile.am
@@ -78,10 +78,10 @@ if SOLARIS_ASM_INLINE
# Needs to be built before any files are compiled when using Sun compilers
# so in*/out* inline definitions are properly processed.
-BUILT_SOURCES += os-support/solaris/solaris-$(SOLARIS_INOUT_ARCH).il
+BUILT_SOURCES += os-support/solaris/solaris-@SOLARIS_INOUT_ARCH@.il
-os-support/solaris/solaris-$(SOLARIS_INOUT_ARCH).il:
- cd os-support/solaris ; make solaris-$(SOLARIS_INOUT_ARCH).il
+os-support/solaris/solaris-@SOLARIS_INOUT_ARCH@.il:
+ cd os-support/solaris ; make solaris-@SOLARIS_INOUT_ARCH@.il
endif
# do not use $(mkdir_p) if you want automake 1.7 to work