summaryrefslogtreecommitdiff
path: root/hw/xfree86/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <idr@us.ibm.com>2006-10-24 08:57:59 -0700
committerIan Romanick <idr@us.ibm.com>2006-10-24 08:57:59 -0700
commit8b909135664abb69ada522e8e39495d9eca717ac (patch)
tree318a3d943ac8a81bfbb4f2b210a782028b54e5d7 /hw/xfree86/Makefile.am
parent21291d6ca7188e5733ed0c93215ee0f1f0f90cc9 (diff)
parent948a97b97e93cee05a23f1f1ae699c5e181bc8ce (diff)
Merge branch 'master' of git+ssh://git.freedesktop.org/git/xorg/xserver into pci-rework
Conflicts: hw/xfree86/Makefile.am hw/xfree86/common/xf86.h hw/xfree86/common/xf86DoScanPci.c hw/xfree86/os-support/bus/linuxPci.c hw/xfree86/scanpci/extrapci.ids hw/xfree86/scanpci/pci.ids hw/xfree86/scanpci/pciid2c.pl hw/xfree86/scanpci/xf86PciStdIds.h
Diffstat (limited to 'hw/xfree86/Makefile.am')
-rw-r--r--hw/xfree86/Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/hw/xfree86/Makefile.am b/hw/xfree86/Makefile.am
index 830cf2977..e138db88f 100644
--- a/hw/xfree86/Makefile.am
+++ b/hw/xfree86/Makefile.am
@@ -1,13 +1,19 @@
+include $(top_srcdir)/cpprules.in
+
if DRI
DRI_SUBDIR = dri
endif
+if XF86UTILS
+XF86UTILS_SUBDIR = utils
+endif
+
DOC_SUBDIR = doc
SUBDIRS = common ddc dummylib i2c x86emu int10 fbdevhw os-support parser rac \
ramdac shadowfb vbe vgahw xaa xf1bpp xf4bpp xf8_16bpp \
xf8_32bpp loader dixmods exa \
- $(DRI_SUBDIR) utils $(DOC_SUBDIR)
+ $(DRI_SUBDIR) $(XF86UTILS_SUBDIR) $(DOC_SUBDIR)
DIST_SUBDIRS = common ddc dummylib i2c x86emu int10 fbdevhw os-support \
parser rac ramdac shadowfb vbe vgahw xaa xf1bpp xf4bpp \
@@ -78,7 +84,23 @@ endif
optionsdir = $(libdir)/X11
dist_options_DATA = Options
+BUILT_SOURCES = xorg.conf.example
+CLEAN = xorg.conf.example xorg.conf.example.pre
EXTRA_DIST = xorgconf.cpp
+CPP_FILES_FLAGS = \
+ -DRGBPATH=\"$(RGB_DB)\" \
+ -DLOCALFONTPATH="\"$(BASE_FONT_PATH)/local\"" \
+ -DMISCFONTPATH="\"$(BASE_FONT_PATH)/misc\"" \
+ -DT1FONTPATH="\"$(BASE_FONT_PATH)/Type1\"" \
+ -DTRUETYPEFONTPATH="\"$(BASE_FONT_PATH)/TTF\"" \
+ -DCIDFONTPATH="\"$(BASE_FONT_PATH)/CID\"" \
+ -DDPI75FONTPATH="\"$(BASE_FONT_PATH)/75dpi\"" \
+ -DDPI100FONTPATH="\"$(BASE_FONT_PATH)/100dpi\"" \
+ -DMODULEPATH=\"$(DEFAULT_MODULE_PATH)\"
+
relink:
rm -f Xorg && $(MAKE) Xorg
+
+xorg.conf.example.pre: xorgconf.cpp
+ cp $< $@