summaryrefslogtreecommitdiff
path: root/hw/xfree86/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2006-06-16 10:17:51 -0700
committerEric Anholt <anholt@FreeBSD.org>2006-06-16 10:17:51 -0700
commit868e2cab706e317618646e064b0559d4e68c7b32 (patch)
treebfcdb62b841f4ce5c5cc36a60b8a7c68bf96ef42 /hw/xfree86/Makefile.am
parent53f74b6aa95fe57fda45fd8a051595e772f00402 (diff)
Add explicit dependencies (Xorg_DEPENDENCIES = ) on the internal libraries
(such as libcw.la) that we link into the server, causing it to be rebuild automatically when they're updated. Some system libraries are included, but don't appear to cause any harm. You would think this would be automatic...
Diffstat (limited to 'hw/xfree86/Makefile.am')
-rw-r--r--hw/xfree86/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/hw/xfree86/Makefile.am b/hw/xfree86/Makefile.am
index 8665926f6..77d1dd844 100644
--- a/hw/xfree86/Makefile.am
+++ b/hw/xfree86/Makefile.am
@@ -43,6 +43,9 @@ XORG_LIBS = \
dixmods/libdixmods.la \
@XORG_LIBS@
+Xorg_DEPENDENCIES = \
+ $(XORG_LIBS)
+
Xorg_LDADD = $(XORG_LIBS) \
@XSERVER_LIBS@ \
dixmods/libxorgxkb.la