summaryrefslogtreecommitdiff
path: root/fb/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-08-11 14:36:29 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-08-11 14:36:29 +0000
commit3e471ddf1dbf58ed021d6f31bdaf438872f03ca8 (patch)
treee8070decce98a4f3ede75e3052bd157fbb1a1639 /fb/Makefile.am
parent130fffc0cdbfdc29f33f1ee97c09e744c19e243a (diff)
Add check for whether the platform is MMX capable and add the relevant
flags if so.
Diffstat (limited to 'fb/Makefile.am')
-rw-r--r--fb/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/fb/Makefile.am b/fb/Makefile.am
index a50c1034f..7c8dce107 100644
--- a/fb/Makefile.am
+++ b/fb/Makefile.am
@@ -4,6 +4,11 @@ AM_CFLAGS = $(DIX_CFLAGS)
sdk_HEADERS = fb.h fbrop.h fbpseudocolor.h fboverlay.h
+if MMX_CAPABLE
+AM_CFLAGS += -mmmx -msse -Winline --param inline-unit-growth=10000 \
+ --param large-function-growth=10000 -DUSE_MMX
+endif
+
libfb_la_SOURCES = \
fb.h \
fb24_32.c \